Zyxel GS1920-24V2 network switch Managed Gigabit Ethernet (10/100/1000) Black
Review the specifications, then ask our team for current pricing and availability.
Product photos load online
GS1920-24V2, 24x 1G RJ-45, 4x 1G RJ-45/SFP, 56 Gbps, 42 Mpps, 441x131x44 mm
Part GS1920-24v2 · UPC 760559125561
Catalog availability is a file snapshot. Call to confirm stock and pricing before ordering.
Add to cart Continue browsing- NebulaFlex™ gives you the flexibility to switch between standalone and our license-free Nebula cloud management
- Nebula cloud management allows easy deployment real-time configurations and effortless access to all your cloud devices anytime
- Using user-friendly web-based GUI to manage and set up the switch without learning complex CLI
- Smart fan and fanless designs offer silent operations in your office
- Check real-time status intuitively by cloud and PoE LED indicators
About this product
The GS1920v2 series extends the success of the best-selling GS1920 series with a stylish new look and enables cloud manageability with Zyxel NebulaFlexTM technology.
What’s new?
The GS1920v2 series comes with a fresh, modern look, a more intuitive user experience, and a new member—the 8HP model.
Manage it your way!
The GS1920v2 series introduces Zyxel NebulaFlexTM, which allows you to easily switch between standalone mode and our license-free Nebula cloud management platform anytime with just a few simple clicks.
Maximum flexibility for your Gig
The GS1920v2 series is ideal for SMB deployment in multiple scenarios, with its unique port combinations futureproofing your network to ensure easy growth down the road.
Whisper-quiet operation
Smart fan and fanless designs for silent operation in your workplace.
User-friendly LED indicators
View real-time status instantly with cloud and PoE power-usage LED indicators.
Power more devices more easily
Provides 30W per port and a wide range of power budget options from 130W to 375W—ideal for denser PoE deployments.
Default consumption mode boosts efficiency by delivering the actual power required.
Zyxel ONE Network
Use the complimentary ZON Utility to configure and discover switches, WLANs, and gateways in your network with one click.
Designed for the long haul
A web smart managed switch with an enterprise-grade hardware design. Built-in state-of-the-art hardware technology brings high quality and robustness to SMB networks.
Manufacturer warranty information
Limited life-time
Management features
- Switch type
- Managed
- Quality of Service (QoS) support
- Yes
- ARP inspection
- Yes
- System event log
- Yes
- MIB support
- RFC 1066, RFC 1213, RFC 1157, RFC 1493, RFC 1643, RFC 1757, RFC 2011.2012,2013, RFC 2233, RFC 2358, RFC 2674, RFC 2819,2925, RFC 3621, RFC 4022, RFC 4113, RFC 4292, RFC 4293
Ports & interfaces
- Basic switching RJ-45 Ethernet ports quantity
- 24
- Basic switching RJ-45 Ethernet ports type
- Gigabit Ethernet (10/100/1000)
- Combo SFP ports quantity
- 4
- Fiber optic connector
- SFP
Network
- Networking standards
- IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
- 10G support
- No
- Copper ethernet cabling technology
- 100BASE-TX, 1000BASE-T
- Flow control support
- Yes
- Rate limiting
- Yes
- Spanning tree protocol
- Yes
- VLAN support
- Yes
- Virtual LAN features
- Private VLAN, Voice VLAN, Protocol-based VLAN, MAC address-based VLAN, Port-based VLAN, IP subnet–based VLAN
Optical fiber
- Fiber ethernet cabling technology
- 1000BASE-X
Data transmission
- Switching capacity
- 56 Gbit/s
- Forwarding rate
- 42 Mpps
- MAC address table
- 16000 entries
- Packet buffer memory
- 1.5 MB
Security
- DHCP features
- DHCP snooping, DHCP relay, DHCPv6 relay, DHCP client
- Access Control List (ACL)
- Yes
- IGMP snooping
- Yes
- Security algorithms
- 802.1x RADIUS, SNMP, SNMPv3
- MAC address filtering
- Yes
- IP-MAC-Port binding
- Yes
- Authentication
- Guest VLAN, Port-based authentication
- Password protection
- Yes
- Authentication type
- IEEE 802.1x, RADIUS
- CPU defense
- Yes
- Queue scheduling algorithms
- SPQ, WFQ, Weighted Round Robin (WRR)
Multicast features
- Multicast support
- Yes
Design
- Rack mounting
- Yes
- Product colour
- Black
- LED indicators
- Yes
- Safety
- LVD, BSMI
- Electromagnetic compatibility
- FCC 15 A, CE A, BSMI EMC
Performance
- Internal memory
- 256 MB
- Flash memory
- 32 MB
- Noise level
- 0 dB
- Mean time between failures (MTBF)
- 911301 h
Power
- AC input voltage
- 100 - 240 V
- AC input frequency
- 50 - 60 Hz
- Power consumption (max)
- 22.5 W
Power over Ethernet (PoE)
- Power over Ethernet (PoE)
- No
Operational conditions
- Operating temperature (T-T)
- 0 - 50 °C
- Storage temperature (T-T)
- -40 - 70 °C
- Operating relative humidity (H-H)
- 10 - 95%
- Storage relative humidity (H-H)
- 10 - 95%
- Heat dissipation
- 76.73 BTU/h
Weight & dimensions
- Width
- 441 mm
- Depth
- 131 mm
- Height
- 44 mm
- Weight
- 2.1 kg
Packaging content
- Cables included
- AC
- Rack mount kit
- Yes
Packaging data
- Package width
- 558 mm
- Package depth
- 214 mm
- Package height
- 79 mm
- Package weight
- 2.91 kg
Certificates
- Certification
- RoHS
Logistics data
- Harmonized System (HS) code
- 85176990
Specifications and images: Database Right data-sheet 2026 Icecat. All rights reserved. Supplied as is, without warranty. Specs Icecat · Open Content License
