Call 800-593-4042My account
Product specifications

Zyxel GS1900-24E network switch Managed Gigabit Ethernet (10/100/1000) Black

Review the specifications, then ask our team for current pricing and availability.

24 port GbE Smart Managed Switch, IEEE 802.3az

Part GS1900-24E · UPC 760559129514

Catalog availability is a file snapshot. Call to confirm stock and pricing before ordering.

Add to cart Continue browsing

Management features

Switch type
Managed
Quality of Service (QoS) support
Yes
MIB support
RFC 1213 MIB II, RFC 2819, RFC 1215, RFC 1493

Ports & interfaces

Basic switching RJ-45 Ethernet ports quantity
24
Basic switching RJ-45 Ethernet ports type
Gigabit Ethernet (10/100/1000)
Gigabit Ethernet (copper) ports quantity
24

Network

Networking standards
IEEE 802.1p, IEEE 802.3, IEEE 802.3ab, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x
Copper ethernet cabling technology
1000BASE-T, 100BASE-T, 10BASE-T
Flow control support
Yes
Broadcast storm control
Yes
Rate limiting
Yes

Security

Security algorithms
802.1x RADIUS
MAC address filtering
Yes
SSH/SSL support
Yes

Protocols

Management protocols
SNMP v1,v2,v3, RMON (1,2,3,9)

Design

Product colour
Black
Safety
LVD EN60950-1, BSMI CNS14336-1

Power over Ethernet (PoE)

Power over Ethernet (PoE)
No

Certificates

Certification
CE, FCC, C-Tick, Class A (GS1900-8HP/24/24HP/48/48HP) CE, FCC, C-Tick, Class B (GS1900-8/16/24E) BSMI CNS13438

Specifications and images: Database Right data-sheet 2026 Icecat. All rights reserved. Supplied as is, without warranty. Specs Icecat · Open Content License

Development preview

Review your request.

No message has been sent. This draft stays on this device.